Author Topic: Win64 error on 1.0.1 client  (Read 137 times)

tiero

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
  • Welcome to our ColossusCoin-Forum!
    • View Profile
Win64 error on 1.0.1 client
« on: January 15, 2018, 10:50:29 AM »
Getting this far too frequently: MinGW Runtime Assertion fatal error.

Assertion failed!
File: main.cpp, Line 1914
Expression: pindex->GetBlockHash() == view.GetBestBlock()


I've re-downloaded the client and rebuilt the blockchain multiple times. Still get it randomly.

Any fix?

tiero

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
  • Welcome to our ColossusCoin-Forum!
    • View Profile
Re: Win64 error on 1.0.1 client
« Reply #1 on: January 15, 2018, 04:41:03 PM »
Additional, from debug.log:

2018-01-16 00:37:34 *** System error while flushing: CDB : Error -30974, can't open database
2018-01-16 00:38:53 CDBEnv::EnvShutdown : Error -30974 shutting down database environment: DB_RUNRECOVERY: Fatal error, run database recovery
2018-01-16 00:38:53 Shutdown: done

tiero

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
  • Welcome to our ColossusCoin-Forum!
    • View Profile
Re: Win64 error on 1.0.1 client
« Reply #2 on: January 15, 2018, 05:20:00 PM »
Looks like a common thing with -qt clients. Found a bunch of things to try, mostly rebuilding the blockchain (tried that) and -salvagewallet on the command line. Fingers crossed it's a wallet issue and this fixes it.

tiero

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
  • Welcome to our ColossusCoin-Forum!
    • View Profile
Re: Win64 error on 1.0.1 client
« Reply #3 on: January 16, 2018, 04:34:34 AM »
Appears to be fixed.